ClaimCapture requires the use of Microsoft's Internet Explorer (IE) browser, version 5.5 or higher. Please click the button below to download the latest version of IE.